cve.bz

CVE-2025-30214

8.0 highEPSS 0.4%

High (8.0) in frappe frappe. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in frappe 14.89.0, 15.51.0.

Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.

Severity

CVSS 4.0

8.0 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 35% of CVEs (scores of 2026-10-31)
CWEs
CWE-200, CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qrv3-jc3h-f3m6PyPIfrappe<14.89.014.89.0
GHSA-qrv3-jc3h-f3m6PyPIfrappe>=15.0.0 <15.51.015.51.0
PYSEC-2026-1392PyPIfrappe<14.89.0
>=15.0.0 <15.51.0
14.89.0, 15.51.0

References

Check your stackJSON