cve.bz

CVE-2025-30145

7.5 highEPSS 0.5%

High (7.5) in osgeo geoserver. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in org.geoserver.web:gs-web-app 2.25.7, 2.26.3.

GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 43% of CVEs (scores of 2026-10-31)
CWE
CWE-835
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gr67-pwcv-76gfMavenorg.geoserver.web:gs-web-app>=2.26.0 <2.26.32.26.3
GHSA-gr67-pwcv-76gfMavenorg.geoserver:gs-wms>=2.26.0 <2.26.32.26.3
GHSA-gr67-pwcv-76gfMavenorg.geoserver.extension:gs-wps-core>=2.26.0 <2.26.32.26.3
GHSA-gr67-pwcv-76gfMavenorg.geoserver.web:gs-web-app<2.25.72.25.7
GHSA-gr67-pwcv-76gfMavenorg.geoserver:gs-wms<2.25.72.25.7
GHSA-gr67-pwcv-76gfMavenorg.geoserver.extension:gs-wps-core<2.25.72.25.7

References

Check your stackJSON