cve.bz

CVE-2025-30067

7.2 highEPSS 0.9%

High (7.2) in apache kylin. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in org.apache.kylin:kylin 5.0.2.

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

Severity

CVSS 3.1

7.2 high
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-29m8-wh9p-5wc4Mavenorg.apache.kylin:kylin>=4.0.0 <5.0.25.0.2

References

Check your stackJSON