cve.bz

CVE-2025-27821

7.3 highEPSS 0.9%

High (7.3) in apache hadoop. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in org.apache.hadoop:hadoop-hdfs-native-client 3.4.2.

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Severity

CVSS 3.1

7.3 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-31)
CWE
CWE-787
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-92cc-952p-v8rhMavenorg.apache.hadoop:hadoop-hdfs-native-client>=3.2.0 <3.4.23.4.2

References

Check your stackJSON