cve.bz

CVE-2025-27407

9.0 criticalEPSS 3.1%

Critical (9.0). EPSS 3.1% chance of exploitation in the next 30 days. Fixed in graphql 1.11.11, 1.12.25, 1.13.24.

graphql-ruby is a Ruby implementation of GraphQL. Starting in version 1.11.5 and prior to versions 1.11.8, 1.12.25, 1.13.24, 2.0.32, 2.1.14, 2.2.17, and 2.3.21, loading a malicious schema definition in `GraphQL::Schema.from_introspection` (or `GraphQL::Schema::Loader.load`) can result in remote code execution. Any system which loads a schema by JSON from an untrusted source is vulnerable, including those that use GraphQL::Client to load external schemas via GraphQL introspection. Versions 1.11.8, 1.12.25, 1.13.24, 2.0.32, 2.1.14, 2.2.17, and 2.3.21 contain a patch for the issue.

Severity

CVSS 3.1

9.0 critical
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
3.1% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-q92j-grw3-h492RubyGemsgraphql>=2.4.0 <2.4.132.4.13
GHSA-q92j-grw3-h492RubyGemsgraphql>=2.3.0 <2.3.212.3.21
GHSA-q92j-grw3-h492RubyGemsgraphql>=2.2.0 <2.2.172.2.17
GHSA-q92j-grw3-h492RubyGemsgraphql>=2.1.0 <2.1.152.1.15
GHSA-q92j-grw3-h492RubyGemsgraphql>=2.0.0 <2.0.322.0.32
GHSA-q92j-grw3-h492RubyGemsgraphql>=1.13.0 <1.13.241.13.24
GHSA-q92j-grw3-h492RubyGemsgraphql>=1.12.0 <1.12.251.12.25
GHSA-q92j-grw3-h492RubyGemsgraphql>=1.11.5 <1.11.111.11.11

References

Check your stackJSON