cve.bz

CVE-2025-23388

8.2 highEPSS 0.6%

High (8.2). EPSS 0.6% chance of exploitation in the next 30 days. Fixed in github.com/rancher/rancher 2.10.3, 2.8.13, 2.9.7.

A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.

Severity

CVSS 3.1

8.2 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-31)
CWE
CWE-121
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xr9q-h9c7-xw8qGogithub.com/rancher/rancher>=2.8.0 <2.8.132.8.13
GHSA-xr9q-h9c7-xw8qGogithub.com/rancher/rancher>=2.9.0 <2.9.72.9.7
GHSA-xr9q-h9c7-xw8qGogithub.com/rancher/rancher>=2.10.0 <2.10.32.10.3
GO-2025-3491Gogithub.com/rancher/rancherall versionsno fix published

References

Check your stackJSON