cve.bz

CVE-2025-23061

9.8 criticalEPSS 7.2%

Critical (9.8) in mongoosejs mongoose. EPSS 7.2% chance of exploitation in the next 30 days. Fixed in mongoose 6.13.6, 7.8.4, 8.9.5.

Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection. NOTE: this issue exists because of an incomplete fix for CVE-2024-53900.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
7.2% chance of exploitation in the next 30 days; higher than 94% of CVEs (scores of 2026-11-01)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vg7j-7cwx-8wgwnpmmongoose>=8.0.0-rc0 <8.9.58.9.5
GHSA-vg7j-7cwx-8wgwnpmmongoose>=7.0.0-rc0 <7.8.47.8.4
GHSA-vg7j-7cwx-8wgwnpmmongoose<6.13.66.13.6

References

Check your stackJSON