cve.bz

CVE-2025-23015

8.8 highEPSS 1.0%

High (8.8) in apache cassandra. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in org.apache.cassandra:cassandra-all 3.0.31, 3.11.18, 4.0.16.

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.0% chance of exploitation in the next 30 days; higher than 63% of CVEs (scores of 2026-10-31)
CWE
CWE-267
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wmcc-9vch-jmx4Mavenorg.apache.cassandra:cassandra-all>=5.0-alpha1 <5.0.35.0.3
GHSA-wmcc-9vch-jmx4Mavenorg.apache.cassandra:cassandra-all>=4.1-alpha1 <4.1.84.1.8
GHSA-wmcc-9vch-jmx4Mavenorg.apache.cassandra:cassandra-all>=4.0-alpha1 <4.0.164.0.16
GHSA-wmcc-9vch-jmx4Mavenorg.apache.cassandra:cassandra-all>=3.1 <3.11.183.11.18
GHSA-wmcc-9vch-jmx4Mavenorg.apache.cassandra:cassandra-all<3.0.313.0.31

References

Check your stackJSON