cve.bz

CVE-2025-2177

6.9 mediumEPSS 0.6%

Medium (6.9) in zapping-vbi zvbi. EPSS 0.6% chance of exploitation in the next 30 days.

A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Severity

CVSS 4.0

6.9 medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 51% of CVEs (scores of 2026-10-31)
CWEs
CWE-190, CWE-189
Published
Modified
Record from
the NVD, synced

Affected

References

Check your stackJSON