cve.bz

CVE-2025-21614

7.5 highEPSS 0.7%

High (7.5) in go-git project go-git. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in github.com/go-git/go-git/v5 5.13.0.

go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)
CWE
CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r9px-m959-cxf4Gogopkg.in/src-d/go-git.v4>=4.0.0 <=4.13.1no fix published
GHSA-r9px-m959-cxf4Gogithub.com/go-git/go-git/v5<5.13.05.13.0
GHSA-r9px-m959-cxf4Gogithub.com/go-git/go-git>=4.0.0 <=4.13.1no fix published
GO-2025-3367Gogithub.com/go-git/go-git/v4>=4.0.0no fix published
GO-2025-3367Gogithub.com/go-git/go-git/v5<5.13.05.13.0
GO-2025-3367Gogopkg.in/src-d/go-git.v4>=4.0.0no fix published

References

Check your stackJSON