cve.bz

CVE-2025-1756

7.8 highEPSS 0.2%

High (7.8). EPSS 0.2% chance of exploitation in the next 30 days. Fixed in mongosh 2.3.0.

mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 5% of CVEs (scores of 2026-10-31)
CWE
CWE-426
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f5w3-73h4-jpcmnpmmongosh<2.3.02.3.0

References

Check your stackJSON