cve.bz

CVE-2025-1753

7.8 highEPSS 1.1%

High (7.8) in llamaindex llamaindex. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in llama-index-cli 0.4.1.

LLama-Index CLI version v0.12.20 contains an OS command injection vulnerability. The vulnerability arises from the improper handling of the `--files` argument, which is directly passed into `os.system`. An attacker who controls the content of this argument can inject and execute arbitrary shell commands. This vulnerability can be exploited locally if the attacker has control over the CLI arguments, and remotely if a web application calls the LLama-Index CLI with a user-controlled filename. This issue can lead to arbitrary code execution on the affected system.

Severity

CVSS 3.0

7.8 high
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g99h-56mw-8263PyPIllama-index-cli<0.4.10.4.1
PYSEC-2025-246PyPIllama-index<=0.12.20no fix published
PYSEC-2026-1557PyPIllama-index-cli<0.4.10.4.1

References

Check your stackJSON