cve.bz

CVE-2025-14287

8.8 highEPSS 1.5%

High (8.8) in lfprojects mlflow. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in mlflow 3.8.0rc0.

A command injection vulnerability exists in mlflow/mlflow versions before v3.7.0, specifically in the `mlflow/sagemaker/__init__.py` file at lines 161-167. The vulnerability arises from the direct interpolation of user-supplied container image names into shell commands without proper sanitization, which are then executed using `os.system()`. This allows attackers to execute arbitrary commands by supplying malicious input through the `--container` parameter of the CLI. The issue affects environments where MLflow is used, including development setups, CI/CD pipelines, and cloud deployments.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWEs
CWE-94, CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xch3-2f9x-wh9fPyPImlflow<3.8.0rc03.8.0rc0
PYSEC-2026-2661PyPImlflow<3.8.0rc03.8.0rc0

References

Check your stackJSON