High (8.8). EPSS 1.9% chance of exploitation in the next 30 days. Fixed in setuptools 70.0.0.
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Severity
CVSS 3.0
8.8 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
1.9% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)