Medium (5.3). EPSS 1.9% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat 10.1.34, 11.0.2, 9.0.98.
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions
may also be affected.
Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
Severity
CVSS 3.1
5.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
1.9% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)