cve.bz

CVE-2024-54133

2.3 lowEPSS 1.0%

Low (2.3). EPSS 1.0% chance of exploitation in the next 30 days. Fixed in actionpack 7.0.8.7, 7.1.5.1, 7.2.2.1.

Action Pack is a framework for handling and responding to web requests. There is a possible Cross Site Scripting (XSS) vulnerability in the `content_security_policy` helper starting in version 5.2.0 of Action Pack and prior to versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1. Applications which set Content-Security-Policy (CSP) headers dynamically from untrusted user input may be vulnerable to carefully crafted inputs being able to inject new directives into the CSP. This could lead to a bypass of the CSP and its protection against XSS and other attacks. Versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1 contain a fix. As a workaround, applications can avoid setting CSP headers dynamically from untrusted input, or can validate/sanitize that input.

Severity

CVSS 4.0

2.3 low
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vfm5-rmrh-j26vRubyGemsactionpack>=5.2.0 <7.0.8.77.0.8.7
GHSA-vfm5-rmrh-j26vRubyGemsactionpack>=7.1.0 <7.1.5.17.1.5.1
GHSA-vfm5-rmrh-j26vRubyGemsactionpack>=7.2.0 <7.2.2.17.2.2.1
GHSA-vfm5-rmrh-j26vRubyGemsactionpack>=8.0.0 <8.0.0.18.0.0.1

References

Check your stackJSON