cve.bz

CVE-2024-53847

5.1 mediumEPSS 0.5%

Medium (5.1). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in trix 1.3.3, 2.1.9.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

Severity

CVSS 4.0

5.1 medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6vx4-v2jw-qwqhnpmtrix>=2.0.0 <2.1.92.1.9
GHSA-6vx4-v2jw-qwqhnpmtrix>=1.0.0 <1.3.31.3.3

References

Check your stackJSON