cve.bz

CVE-2024-52809

5.3 mediumEPSS 0.7%

Medium (5.3). EPSS 0.7% chance of exploitation in the next 30 days. Fixed in @intlify/core-base 10.0.5, 9.14.2.

vue-i18n is an internationalization plugin for Vue.js. In affected versions vue-i18n can be passed locale messages to `createI18n` or `useI18n`. When locale message ASTs are generated in development mode there is a possibility of Cross-site Scripting attack. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Severity

CVSS 4.0

5.3 medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
EPSS
0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9r9m-ffp6-9x4vnpm@intlify/core-base>=9.3.0 <9.14.29.14.2
GHSA-9r9m-ffp6-9x4vnpmvue-i18n>=9.3.0 <9.14.29.14.2
GHSA-9r9m-ffp6-9x4vnpm@intlify/core>=9.3.0 <9.14.29.14.2
GHSA-9r9m-ffp6-9x4vnpm@intlify/vue-i18n-core>=9.3.0 <9.14.29.14.2
GHSA-9r9m-ffp6-9x4vnpmpetite-vue-i18n>=10.0.0 <10.0.510.0.5
GHSA-9r9m-ffp6-9x4vnpm@intlify/core-base>=10.0.0 <10.0.510.0.5
GHSA-9r9m-ffp6-9x4vnpmvue-i18n>=10.0.0 <10.0.510.0.5
GHSA-9r9m-ffp6-9x4vnpm@intlify/core>=10.0.0 <10.0.510.0.5
GHSA-9r9m-ffp6-9x4vnpm@intlify/vue-i18n-core>=10.0.0 <10.0.510.0.5

References

Check your stackJSON