cve.bz

CVE-2024-48963

7.5 highEPSS 0.5%

High (7.5) in snyk snyk cli. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in snyk-php-plugin 1.10.0.

The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted PHP project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.

Severity

CVSS 4.0

7.5 high
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-69f9-h8f9-7vjfnpmsnyk-php-plugin<1.10.01.10.0

References

Check your stackJSON