cve.bz

CVE-2024-45401

7.1 highEPSS 0.2%

High (7.1) in stripe stripe cli. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in github.com/stripe/stripe-cli 1.21.3.

stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fv4g-gwpj-74grGogithub.com/stripe/stripe-cli>=1.11.1 <1.21.31.21.3
GO-2024-3119Gogithub.com/stripe/stripe-cli>=1.11.1 <1.21.31.21.3

References

Check your stackJSON