cve.bz

CVE-2024-45216

9.8 criticalEPSS 93%

Critical (9.8) in apache solr. EPSS 93% chance of exploitation in the next 30 days. Fixed in org.apache.solr:solr 8.11.4, 9.7.0.

Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
93% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWEs
CWE-287, CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mjvf-4h88-6xm3Mavenorg.apache.solr:solr>=5.3.0 <8.11.48.11.4
GHSA-mjvf-4h88-6xm3Mavenorg.apache.solr:solr>=9.0.0 <9.7.09.7.0

References

Check your stackJSON