cve.bz

CVE-2024-42490

7.5 highEPSS 0.5%

High (7.5) in goauthentik authentik. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in goauthentik.io 2024.4.4, 2024.6.4.

authentik is an open-source Identity Provider. Several API endpoints can be accessed by users without correct authentication/authorization. The main API endpoints affected by this are /api/v3/crypto/certificatekeypairs/<uuid>/view_certificate/, /api/v3/crypto/certificatekeypairs/<uuid>/view_private_key/, and /api/v3/.../used_by/. Note that all of the affected API endpoints require the knowledge of the ID of an object, which especially for certificates is not accessible to an unprivileged user. Additionally the IDs for most objects are UUIDv4, meaning they are not easily guessable/enumerable. authentik 2024.4.4, 2024.6.4 and 2024.8.0 fix this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-31)
CWE
CWE-285
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qxqc-27pr-wgc8Gogoauthentik.io>=2024.6.0-rc1 <2024.6.42024.6.4
GHSA-qxqc-27pr-wgc8Gogoauthentik.io<2024.4.42024.4.4
GO-2024-3085Gogoauthentik.ioall versionsno fix published

References

Check your stackJSON