cve.bz

CVE-2024-42473

9.8 criticalEPSS 0.5%

Critical (9.8) in openfga openfga. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in github.com/openfga/openfga 1.5.9.

OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3f6g-m4hr-59h8Gogithub.com/openfga/openfga>=1.5.7 <1.5.91.5.9
GO-2024-3061Gogithub.com/openfga/openfga>=1.5.7 <1.5.91.5.9

References

Check your stackJSON