cve.bz

CVE-2024-4216

5.4 mediumEPSS 0.5%

Medium (5.4). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in pgadmin4 8.6.

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xv64-8p4r-94gqPyPIpgadmin4<8.68.6
PYSEC-2026-1777PyPIpgadmin4<8.68.6

References

Check your stackJSON