cve.bz

CVE-2024-4181

8.8 highEPSS 2.1%

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Severity

CVSS 3.0

8.8 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
2.1% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pw38-xv9x-h8chPyPIllama-index<0.10.130.10.13
GHSA-pw38-xv9x-h8chPyPIllama-index-llms-rungpt<0.1.30.1.3
PYSEC-2024-324PyPIllama-index>=0.9.47 <0.10.130.10.13
PYSEC-2026-1565PyPIllama-index-llms-rungpt<0.1.30.1.3

References

Check your stackJSON