cve.bz

CVE-2024-40637

7.3 highEPSS 0.4%

dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. This issue has been fixed in versions 1.8.0, 1.6.14 and 1.7.14. Users are advised to upgrade. There are no kn own workarounds for this vulnerability. Users updating to either 1.6.14 or 1.7.14 will need to set `flags.require_explicit_package_overrides_for_builtin_materializations: False` in their configuration in `dbt_project.yml`.

Severity

CVSS 3.1

7.3 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 31% of CVEs (scores of 2026-10-30)
CWEs
CWE-94, CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p3f3-5ccg-83xqPyPIdbt-core>=1.6.0 <1.6.141.6.14
GHSA-p3f3-5ccg-83xqPyPIdbt-core>=1.7.0 <1.7.141.7.14
PYSEC-2024-66PyPIdbt-core>=1.7.0 <1.7.14
<1.6.14
1.7.14, 1.6.14

References

Check your stackJSON