cve.bz

CVE-2024-39863

5.4 mediumEPSS 1.0%

Medium (5.4) in apache airflow. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in apache-airflow 2.9.3.

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-j482-47xf-p25cPyPIapache-airflow<2.9.32.9.3
PYSEC-2024-189PyPIapache-airflow<2.9.32.9.3

References

Check your stackJSON