cve.bz

CVE-2024-38356

6.1 mediumEPSS 0.5%

Medium (6.1). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tinymce 5.11.0, 6.8.4, 7.2.0.

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the `noneditable_regexp` option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the `noneditable_regexp` option, any content within an attribute is properly verified to match the configured regular expression before being added. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9hcv-j9pv-qmphnpmtinymce<5.11.05.11.0
GHSA-9hcv-j9pv-qmphNuGetTinyMCE<5.11.05.11.0
GHSA-9hcv-j9pv-qmphPackagisttinymce/tinymce<5.11.05.11.0
GHSA-9hcv-j9pv-qmphnpmtinymce>=6.0.0 <6.8.46.8.4
GHSA-9hcv-j9pv-qmphnpmtinymce>=7.0.0 <7.2.07.2.0
GHSA-9hcv-j9pv-qmphNuGetTinyMCE>=6.0.0 <6.8.46.8.4
GHSA-9hcv-j9pv-qmphNuGetTinyMCE>=7.0.0 <7.2.07.2.0
GHSA-9hcv-j9pv-qmphPackagisttinymce/tinymce>=6.0.0 <6.8.46.8.4
GHSA-9hcv-j9pv-qmphPackagisttinymce/tinymce>=7.0.0 <7.2.07.2.0
GHSA-9hcv-j9pv-qmphPyPIdjango-tinymce<4.1.04.1.0
PYSEC-2026-1301PyPIdjango-tinymce<4.1.04.1.0

References

Check your stackJSON