cve.bz

CVE-2024-33522

6.7 mediumEPSS 0.2%

Medium (6.7). EPSS 0.2% chance of exploitation in the next 30 days. Fixed in github.com/projectcalico/calico 3.26.5, 3.27.3.

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Severity

CVSS 3.1

6.7 medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 12% of CVEs (scores of 2026-10-31)
CWE
CWE-269
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6362-gv4m-53wwGogithub.com/projectcalico/calico<3.26.53.26.5
GHSA-6362-gv4m-53wwGogithub.com/projectcalico/calico>=3.27.0 <3.27.33.27.3
GO-2024-2801Gogithub.com/projectcalico/calicoall versionsno fix published
GO-2024-2801Gogithub.com/projectcalico/calico/v3all versionsno fix published

References

Check your stackJSON