cve.bz

CVE-2024-32463

7.1 highEPSS 0.6%

High (7.1). EPSS 0.6% chance of exploitation in the next 30 days. Fixed in phlex 1.10.1, 1.4.2, 1.5.3.

phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. The filter to detect and prevent the use of the `javascript:` URL scheme in the `href` attribute of an `<a>` tag could be bypassed with tab `\t` or newline `\n` characters between the characters of the protocol, e.g. `java\tscript:`. This vulnerability is fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, and 1.4.2. Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 47% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.10.0 <1.10.11.10.1
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.9.0 <1.9.21.9.2
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.8.0 <1.8.31.8.3
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.7.0 <1.7.21.7.2
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.6.0 <1.6.31.6.3
GHSA-g7xq-xv8c-h98cRubyGemsphlex>=1.5.0 <1.5.31.5.3
GHSA-g7xq-xv8c-h98cRubyGemsphlex<1.4.21.4.2

References

Check your stackJSON