cve.bz

CVE-2024-32077

5.4 mediumEPSS 1.6%

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.6% chance of exploitation in the next 30 days; higher than 75% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-52gm-qmg3-r4qpPyPIapache-airflow>=2.9.0 <2.9.12.9.1
PYSEC-2024-264PyPIapache-airflow<=2.9.0-NA
<=2.9.0-beta1
<=2.9.0-beta2
<=2.9.0-rc1
<=2.9.0-rc2
<=2.9.0-rc3
no fix published

References

Check your stackJSON