cve.bz

CVE-2024-31867

6.5 mediumEPSS 1.2%

Medium (6.5) in apache zeppelin. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.apache.zeppelin:zeppelin-server 0.11.1.

Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qmr3-52xf-wmhxMavenorg.apache.zeppelin:zeppelin-server>=0.8.2 <0.11.10.11.1

References

Check your stackJSON