Medium (6.5) in apache zeppelin. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in org.apache.zeppelin:zeppelin-server 0.11.0.
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access.
This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Severity
CVSS 3.1
6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
1.4% chance of exploitation in the next 30 days; higher than 72% of CVEs (scores of 2026-10-31)