Critical (9.8). EPSS 66% chance of exploitation in the next 30 days. Fixed in pgadmin4 8.5.
pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
66% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)