cve.bz

CVE-2024-30261

3.5 lowEPSS 0.8%

Low (3.5). EPSS 0.8% chance of exploitation in the next 30 days. Fixed in undici 5.28.4, 6.11.1.

Undici is an HTTP/1.1 client, written from scratch for Node.js. An attacker can alter the `integrity` option passed to `fetch()`, allowing `fetch()` to accept requests as valid even if they have been tampered. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.

Severity

CVSS 3.1

3.5 low
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 56% of CVEs (scores of 2026-10-31)
CWE
CWE-284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9qxr-qj54-h672npmundici<5.28.45.28.4
GHSA-9qxr-qj54-h672npmundici>=6.0.0 <6.11.16.11.1

References

Check your stackJSON