cve.bz

CVE-2024-28718

9.8 criticalEPSS 1.1%

Critical (9.8) in openstack magnum. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in magnum 14.1.2, 15.0.2, 16.0.2.

An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 64% of CVEs (scores of 2026-10-31)
CWE
CWE-367
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-jx7x-9r98-h5xrPyPImagnum<14.1.214.1.2
GHSA-jx7x-9r98-h5xrPyPImagnum>=17.0.0.0rc1 <17.0.217.0.2
GHSA-jx7x-9r98-h5xrPyPImagnum>=16.0.0.0rc1 <16.0.216.0.2
GHSA-jx7x-9r98-h5xrPyPImagnum>=15.0.0.0rc1 <15.0.215.0.2
PYSEC-2026-1602PyPImagnum<14.1.2
>=15.0.0.0rc1 <15.0.2
>=16.0.0.0rc1 <16.0.2
>=17.0.0.0rc1 <17.0.2
14.1.2, 15.0.2, 16.0.2, 17.0.2

References

Check your stackJSON