cve.bz

CVE-2024-28199

6.1 mediumEPSS 0.6%

Medium (6.1) in phlex phlex. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in phlex 1.0.1, 1.1.1, 1.2.2.

phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. This was due to improper case-sensitivity in the code that was meant to prevent these attacks. If you render an `<a>` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. If you splat user-provided attributes when rendering any HTML tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user. Patches are available on RubyGems for all 1.x minor versions. Users are advised to upgrade. Users unable to upgrade should consider configuring a content security policy that does not allow `unsafe-inline`.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.9.0 <1.9.11.9.1
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.8.0 <1.8.21.8.2
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.7.0 <1.7.11.7.1
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.6.0 <1.6.21.6.2
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.5.0 <1.5.21.5.2
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.4.0 <1.4.11.4.1
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.3.0 <1.3.31.3.3
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.2.0 <1.2.21.2.2
GHSA-242p-4v39-2v8gRubyGemsphlex>=1.1.0 <1.1.11.1.1
GHSA-242p-4v39-2v8gRubyGemsphlex<1.0.11.0.1

References

Check your stackJSON