Medium (5.9) in apache airflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in apache-airflow 2.8.2.
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.
Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Severity
CVSS 3.1
5.9 medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
0.3% chance of exploitation in the next 30 days; higher than 28% of CVEs (scores of 2026-10-31)