Medium (4.3) in apache superset. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in apache-superset 3.0.4, 3.1.1.
An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Severity
CVSS 3.1
4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-31)