cve.bz

CVE-2024-24779

6.5 mediumEPSS 0.7%

Medium (6.5) in apache superset. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in apache-superset 3.0.4, 3.1.1.

Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
0.7% chance of exploitation in the next 30 days; higher than 54% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wr6g-9wcr-cmqjPyPIapache-superset<3.0.43.0.4
GHSA-wr6g-9wcr-cmqjPyPIapache-superset>=3.1.0 <3.1.13.1.1
PYSEC-2026-1191PyPIapache-superset<3.0.4
>=3.1.0 <3.1.1
3.0.4, 3.1.1

References

Check your stackJSON