cve.bz

CVE-2024-24561

9.8 criticalEPSS 0.9%

Critical (9.8) in vyperlang vyper. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in vyper 0.4.0, 0.4.0b1.

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In versions 0.3.10 and earlier, the bounds check for slices does not account for the ability for start + length to overflow when the values aren't literals. If a slice() function uses a non-literal argument for the start or length variable, this creates the ability for an attacker to overflow the bounds check. This issue can be used to do OOB access to storage, memory or calldata addresses. It can also be used to corrupt the length slot of the respective array.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-31)
CWEs
CWE-787, CWE-119
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9x7f-gwxq-6f2cPyPIvyper<0.4.00.4.0
PYSEC-2024-149PyPIvyper<0.4.0b10.4.0b1

References

Check your stackJSON