cve.bz

CVE-2024-24549

7.5 highEPSS 23%

High (7.5). EPSS 23% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-coyote 10.1.19, 11.0.0-M17, 8.5.99.

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
23% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat:tomcat-coyote>=11.0.0-M1 <11.0.0-M1711.0.0-M17
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat:tomcat-coyote>=10.1.0-M1 <10.1.1910.1.19
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat:tomcat-coyote>=9.0.0-M1 <9.0.869.0.86
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat:tomcat-coyote>=8.5.0 <8.5.998.5.99
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat.embed:tomcat-embed-core>=8.5.0 <8.5.998.5.99
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.0-M1 <9.0.869.0.86
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.0-M1 <10.1.1910.1.19
GHSA-7w75-32cg-r6g2Mavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.0-M1 <11.0.0-M1711.0.0-M17

References

Check your stackJSON