cve.bz

CVE-2024-23841

6.1 mediumEPSS 0.4%

Medium (6.1) in apollographql apollo client. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in @apollo/experimental-nextjs-app-support 0.7.0.

apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-31)
CWE
CWE-80
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rv8p-rr2h-fgpgnpm@apollo/experimental-nextjs-app-support<0.7.00.7.0

References

Check your stackJSON