cve.bz

CVE-2024-23821

4.8 mediumEPSS 0.4%

Medium (4.8) in geoserver geoserver. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.geoserver:gs-gwc 2.23.4, 2.24.1.

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

Severity

CVSS 3.1

4.8 medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 34% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-88wc-fcj9-q3r9Mavenorg.geoserver:gs-gwc>=2.24.0 <2.24.12.24.1
GHSA-88wc-fcj9-q3r9Mavenorg.geoserver:gs-gwc<2.23.42.23.4

References

Check your stackJSON