cve.bz

CVE-2024-23643

4.8 mediumEPSS 0.4%

Medium (4.8) in geoserver geoserver. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.geoserver:gs-gwc-rest 2.23.2, 2.24.1.

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.2 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another administrator’s browser when viewed in the GWC Seed Form. Access to the GWC Seed Form is limited to full administrators by default and granting non-administrators access to this endpoint is not recommended. Versions 2.23.2 and 2.24.1 contain a fix for this issue.

Severity

CVSS 3.1

4.8 medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-56r3-f536-5gf7Mavenorg.geoserver:gs-gwc-rest<2.23.22.23.2
GHSA-56r3-f536-5gf7Mavenorg.geoserver:gs-gwc-rest>=2.24.0 <2.24.12.24.1

References

Check your stackJSON