cve.bz

CVE-2024-23640

4.8 mediumEPSS 0.4%

Medium (4.8) in geoserver geoserver. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.geoserver:gs-main 2.23.3.

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.0 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.3 and 2.24.0 contain a fix for this issue.

Severity

CVSS 3.1

4.8 medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9rfr-pf2x-g4xfMavenorg.geoserver:gs-main<2.23.32.23.3
GHSA-9rfr-pf2x-g4xfMavenorg.geoserver:gs-ows<2.23.32.23.3

References

Check your stackJSON