cve.bz

CVE-2024-23638

6.5 mediumEPSS 60%

Medium (6.5) in squid-cache squid. EPSS 60% chance of exploitation in the next 30 days.

Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
60% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWEs
CWE-672, CWE-825
Published
Modified
Record from
the NVD, synced

Affected

References

Check your stackJSON