Critical (9.8) in apache seata. EPSS 3.3% chance of exploitation in the next 30 days. Fixed in org.apache.seata:seata-core 1.8.1, 2.1.0.
Deserialization of Untrusted Data vulnerability in Apache Seata.
When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol.
This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0.
Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.3% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)