cve.bz

CVE-2024-22369

7.8 highEPSS 0.7%

High (7.8) in apache camel. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in org.apache.camel:camel-sql 3.21.4, 3.22.1, 4.0.4.

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 54% of CVEs (scores of 2026-11-01)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-36xr-4x2f-cfj9Mavenorg.apache.camel:camel-sql>=3.0.0 <3.21.43.21.4
GHSA-36xr-4x2f-cfj9Mavenorg.apache.camel:camel-sql>=3.22.0 <3.22.13.22.1
GHSA-36xr-4x2f-cfj9Mavenorg.apache.camel:camel-sql>=4.0.0 <4.0.44.0.4
GHSA-36xr-4x2f-cfj9Mavenorg.apache.camel:camel-sql>=4.1.0 <4.4.04.4.0

References

Check your stackJSON