cve.bz

CVE-2024-22233

7.5 highEPSS 1.0%

High (7.5) in vmware spring framework. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in org.springframework:spring-core 6.0.16, 6.1.3.

In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: * the application uses Spring MVC * Spring Security 6.1.6+ or 6.2.1+ is on the classpath Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.0% chance of exploitation in the next 30 days; higher than 64% of CVEs (scores of 2026-10-31)
CWE
CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r4q3-7g4q-x89mMavenorg.springframework:spring-core>=6.1.2 <6.1.36.1.3
GHSA-r4q3-7g4q-x89mMavenorg.springframework:spring-core>=6.0.15 <6.0.166.0.16

References

Check your stackJSON